Demo

Probiere ClanSphere aus und teste daran herum. Demo

News - Details
Informationen zur ausgewählten Nachricht.

cSphere - What are the requirements?
09.04.2012 um 14:43 Uhr - hajo ClanSphere Team
English

In our (in most cases weekly) cSphere development report we will try to answer some questions and reveal cool features and changes compared to ClanSphere. This report is focused on the question "what do i need to get it run on my webspace?".

cSphere is written in PHP and as we already announced PHP 5.3.3 will be the oldest version that should work. We make heavy use of namespaces and require PHP 5 style class constructors which lead to that decision. Webspace with PHP 5.4.0 and newer might get a few more options here and there, but nothing important.

Some PHP settings need to be turned off. Most of them are already known as they are checked by the ClanSphere 'system -> software' page. It won't run if e.g. magic quotes, safe mode or register globals are turned on.

On the database side you will need MySQL 5.0, PostgreSQL 9.0, SQLite 3.0 (bundled with PHP) or Microsoft SQL Sever 2012. Any later version should work the same or even better. Support for NoSQL databases is neither planned nor possible due to the relational principle used by our new framework.

German

In unserem (in den meisten Fällen wöchentlich erscheinenden) cSphere Entwicklungsbericht werden wir versuchen einige Fragen zu Beantworten, sowie neue Features und Änderungen gegenüber ClanSphere ankündigen. Dieser Bericht beantwortet die Frage "was werde ich benötigen, damit es auf meinem Webspace läuft?".

cSphere ist in PHP geschrieben und läuft, wie bereits zuvor verkündet, mit PHP 5.3.3 als ältestmöglicher Version. Wir machen viel Gebrauch von Namensräumen und verlangen Klassenkonstruktoren im PHP 5 Stil, was zu dieser Entscheidung führte. Webspace mit PHP 5.4.0 oder neuer wird hier und da über ein paar mehr Optionen verfügen, aber nichts wirklich wichtiges ergänzen.

Einige PHP Einstellungen müssen zudem deaktiviert sein. Die meisten davon sind bereits von der ClanSphere 'system -> software' Seite bekannt. Beispielsweise müssen Magic Quotes, Safe Mode und Register Globals abgeschaltet sein.

Betreffend der Datenbanken werden MySQL 5.0, PostgreSQL 9.0, SQLite 3.0 (bei PHP schon dabei) oder der Microsoft SQL Server 2012 ausreichend sein. Spätere Versionen werden genauso, wenn nicht besser, laufen. Unterstützung für NoSQL Datenbanken ist weder geplant noch möglich, da unser neues Framework mit einem relationalen Prinzip arbeitet.

Kommentare: 2
Seite [1]
uNsLide

31.05.2013

Ort: -
Beiträge: 11
# 1 - 13.04.2012 um 20:03 Uhr

Hi. Does it mean that ClanSphere would use MVC or HMVC patterns to work ?
hajo ClanSphere Team

--

Ort: Barsbüttel
Beiträge: 10000
# 2 - 13.04.2012 um 20:20 Uhr

clansphere has never used design patterns at all.

csphere is going to be our first cms that makes use of oop features. nevertheless it will use many design patterns with slightly modifications to fit into the big picture of loose coupling and low complexity.

mvc was created for desktop or - to better describe it - gui applications, not for the web. there are many frameworks and libraries out there that try to reach mvc as good as they can. this leads to high complexity, close coupling and other downsides (e.g. stupid workarounds). this lead us to the decision to not use mvc or alike patterns at all, but we have used other patterns for the structure.

Bitte Login benutzen, um Kommentare zu schreiben.